NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/54552 (NVMM not run Windows 7 32-bit installed OS from .qcow image)

17.09.2019, 14:24, "" <>:

Synopsis: NVMM not run Windows 7 32-bit installed OS from .qcow image

State-Changed-From-To: open->feedback
State-Changed-When: Tue, 17 Sep 2019 11:24:23 +0000
I saw your email the other day. I committed this change:

 1) Please provide the output of "cpuctl identify 0".

cpu0: highest basic info 0000000d
cpu0: highest extended info 80000008
cpu0: "Intel(R) Core(TM) i5-3550 CPU @ 3.30GHz"
cpu0: Intel Xeon E3-1200v2 and 3rd gen core, Ivy Bridge (686-class), 3292.75 MHz
cpu0: family 0x6 model 0x3a stepping 0x9 (id 0x306a9)
cpu0: features 0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE>
cpu0: features 0xbfebfbff<MCA,CMOV,PAT,PSE36,CLFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2>
cpu0: features 0xbfebfbff<SS,HTT,TM,SBF>
cpu0: features1 0x7fbae3ff<SSE3,PCLMULQDQ,DTES64,MONITOR,DS-CPL,VMX,SMX,EST>
cpu0: features1 0x7fbae3ff<TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE41,SSE42,X2APIC>
cpu0: features2 0x28100800<SYSCALL/SYSRET,XD,RDTSCP,EM64T>
cpu0: features3 0x1<LAHF>
cpu0: features5 0x281<FSGSBASE,SMEP,ERMS>
cpu0: xsave features 0x7<x87,SSE,AVX>
cpu0: xsave instructions 0x1<XSAVEOPT>
cpu0: xsave area size: current 832, maximum 832, xgetbv enabled
cpu0: enabled xsave 0x7<x87,SSE,AVX>
cpu0: I-cache 32KB 64B/line 8-way, D-cache 32KB 64B/line 8-way
cpu0: L2 cache 256KB 64B/line 8-way
cpu0: L3 cache 6MB 64B/line 12-way
cpu0: 64B prefetching
cpu0: ITLB 128 4KB entries 4-way, 2M/4M: 8 entries
cpu0: DTLB 64 4KB entries 4-way, 2M/4M: 32 entries (L0)
cpu0: L2 STLB 512 4KB entries 4-way
cpu0: Initial APIC ID 0
cpu0: Cluster/Package ID 0
cpu0: Core ID 0
cpu0: SMT ID 0
cpu0: MONITOR/MWAIT extensions 0x3<EMX,IBE>
cpu0: monitor-line size 64
cpu0: C1 substates 2
cpu0: C2 substates 1
cpu0: C3 substates 1
cpu0: DSPM-ecx 0x9<HWF,EPB>
cpu0: SEF highest subleaf 00000000
cpu0: Perfmon-eax 0x7300803<VERSION=0x3,GPCounter=0x8,GPBitwidth=0x30>
cpu0: Perfmon-eax 0x7300803<Vectorlen=0x7>
cpu0: Perfmon-edx 0x603<FixedFunc=0x3,FFBitwidth=0x30>
cpu0: microcode version 0x15, platform ID 1

 2) Please update your kernel to the latest -current, because Jul 7 is a
    bit old.

I installed yesterday’s version of 9beta on my computer yesterday,
from here
I downloaded the source and compiled NVMM with version 1.37.
I saw changes in versions here:
I had 1.36
But still the same mistake.

Today I noticed one more thing:
qemu(or libnvmm) at startup win7 tries to identify the processor as athlon, that is, as AMD. My processor is Intel (R) Core (TM) i5-3550 CPU @ 3.30GHz, id 0x306a9

Launched without acceleration (without -accel nvmm)
Windows7 defines the processor as QEMU Virtual CPU version 2.5+
Windows XP (using -accel nvmm) - the processor is correctly detected: Intel (R) Core (TM) i5-3550 CPU @ 3.30GHz
But without using acceleration (without -accel nvmm) it defines how QEMU Virtual CPU version 2.5+

NetBSD 9.99.10 running in qemu with acceleration (using -accel nvmm) correctly defines the processor;
no acceleration (no -accel nvmm) defines QEMU Virtual CPU version 2.5+

I would venture to suggest that qemu (or qemu + nvmm) does not correctly determine the type of processor - therefore, it cannot use / execute processor instructions.

I tried to explicitly set the type of processor - but could not figure it out))

I'll try again, for the sake of the purity of the experiment, to do the same on NetBSD 9.99.10

 3) Please retry with an updated NVMM module. Normally the "hw" value
    printed should be different.

I'll do it again with the latest versions - I'll write.


Home | Main Index | Thread Index | Old Index