NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-macppc/54331: macppc MP kernels fail to boot successfully in -current (8.99.49)

The following reply was made to PR port-macppc/54331; it has been noted by GNATS.

From: "David H. Gutteridge" <>
Subject: Re: port-macppc/54331: macppc MP kernels fail to boot successfully
 in -current (8.99.49)
Date: Wed, 31 Jul 2019 02:27:28 -0400

 On Mon, 2019-07-29 at 19:38 -0400, David H. Gutteridge wrote:
 > Separately, I've now hit an occasion where 8.1_STABLE without debugging
 > options also hangs, which I hadn't seen before. It gets farther than
 > -current: it mounts file systems and tries /sbin/init, and hangs there.
 > I'm going to try some more tests with it and see what happens.
 Hi Michael,
 I can't reproduce that last hanging issue with a non-debug 8.1_STABLE
 MP kernel. Every reboot worked without trouble. (Perhaps there's some
 rare timing condition involved, or perhaps the hardware is getting
 I also tried applying your patch to an 8.1 MP kernel (with DEBUG,
 DIAGNOSTIC, and LOCKDEBUG options enabled), and that gets me past the
 related original panic there, too. As the 8.1 kernel continues booting,
 it gets to the point where it needs to request user input (I have non-
 standard partitioning in this test setup), at which point it panics
 with the following backtrace:
 panic: kernel diagnostic assertion "mutex_owned(&sc->sc_lock)" failed: file "/home/disciple/netbsd-8/src/sys/dev/usb/ohci.c", line 590
 Stopped in pid 0.1 (system) at  netbsd:vpanic+0x140:     addi     r4,  r0,  0x0
 0x00c56a90: at kern_assert+0x68
 0x00c56ad0: at ohci_reset_std_chain+0x518
 0x00c56b30: at ohci_device_intr_start+0xd8
 0x00c56b70: at usbd_start_next+0x6c
 0x00c56b80: at ohci_softintr+0x6a0
 0x00c56be0: at ohci_intr1+0x1f0
 0x00c56c00: at ohci_poll+0x70
 0x00c56c10: at ukbd_cngetc+0x80
 0x00c56c30: at wskbd_cngetc+0x114
 0x00c56c70: at cngetc+0x58
 0x00c56c90: at cngetsn+0x6c
 0x00c56cc0: at setroot+0x174
 0x00c56ea0: at main+0x62c
 0x00c56f10: at 0x1000b4
 (Since -current hangs around USB controller attachment, I wondered if
 that and this new 8.1 panic are somehow related.)

Home | Main Index | Thread Index | Old Index