NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-xen/53965: XEN DomU fails to poweroff in new HEAD kernels

The following reply was made to PR port-xen/53965; it has been noted by GNATS.

From: Robert Elz <kre%munnari.OZ.AU@localhost>
To: Manuel Bouyer <>
Subject: Re: port-xen/53965: XEN DomU fails to poweroff in new HEAD kernels
Date: Sun, 10 Feb 2019 01:25:10 +0700

     Date:        Sat, 9 Feb 2019 19:11:44 +0100
     From:        Manuel Bouyer <>
     Message-ID:  <>
   | On Sat, Feb 09, 2019 at 05:40:01PM +0000, Greg Oster wrote:
   | >  I'm seeing this with an 8.0_STABLE DOM0... I instrumented cpu_reset()
   | >  with printfs before/after the call to HYPERVISOR_reboot():
 That's shutdown -r, right?   I don't have a real need for that,
 so I am not sure I ever tried.    But if I do what it says
 "hit any key to reboot", it doesn't...
    | Just tried a kernel from Jan 11, 2019, and it rebooted without incident....
    | Going to test a Jan 19 kernel next... 
 Sounds good, looks like the current issue might be affecting both
 HEAD and 8.0_STABLE (with any luck it is the same problem.) said:
   |  AFAIK shutdown -r always worked properly for me, even with 8.0. shutdown -p
   | never did 
 shutdown -p has always worked for me.   Still does on my 8.0_STABLE
 test system - but that has a much older kernel still...
 netbsd# uname -a
 NetBSD 8.0_STABLE NetBSD 8.0_STABLE (MUNNARI-DomU) #37: Wed Nov 28 23:08:14 ICT 2018 amd64
 netbsd# shutdown -p now
 Shutdown NOW!
 shutdown: [pid 420]
 netbsd# wall: You have write permission turned off; no reply possible
 *** FINAL System shutdown message from ***            
 System going down IMMEDIATELY                                                  
 Feb  9 18:15:00 netbsd shutdown: poweroff by root: 
 System shutdown time has arrived
 About to run shutdown hooks...
 Stopping cron.
 Stopping inetd.
 Saved entropy to /var/db/entropy-file.
 Sat Feb  9 18:15:03 UTC 2019
 Done running shutdown hooks.
 Feb  9 18:15:08 netbsd syslogd[189]: Exiting on signal 15
 syncing disks... done
 audio0: detached
 (that is back at the sh prompt on the Dom0).
 I'll look see what intervening kernels I have lying around and try a
 few of them - but one big clue from Greg's message is that the change
 that matters is one that has been pulled up to -8 which should narrow
 the field a little.

Home | Main Index | Thread Index | Old Index