NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/53795: i915drmkms causes crash on boot with Atom N270/945GSE netbook

The following reply was made to PR kern/53795; it has been noted by GNATS.

From: Elliott Shue <>
Subject: Re: kern/53795: i915drmkms causes crash on boot with Atom N270/945GSE netbook
Date: Tue, 8 Jan 2019 01:36:20 -0500

 >  You didn't mention what make and model this machine is?
 I did in the original report, it is an ECS E09EI6, DakTech branded in
 my case. It is slightly oddball, with a 1.8" ZIF drive and internal
 USB based Wifi, but I don't think the graphics are anything that
 I tried flashing it to the generic BIOS with no change.
 >  Which specific Linux kernel versions does it work on? Same with
 >  OpenBSD? NetBSD's i915 code is based on Linux 4.4, as is OpenBSD's
 >  (for the most part).
 I ran OpenBSD 6.2 on it for a while. If I remember right the console
 wasn't native resolution, but X was. I've never had an issue with any
 version of Linux in the time I've had it, some before kernel 4.4, some
 after. Just tried live Debian Stretch with kernel 4.9 and no issues
 with console or X.
 >  Is there any more dmesg output than that? I'd expect if you ended up
 >  with working ssh access there'd be more of it.
 That was everything I got with i915drmkms enabled. I get more with it disabled.
 There is something weird going on with i915drmkms enabled because my
 Wifi won't come up when enabled in rc.conf, I added it and sshd to
 rc.local and that works. I should have mentioned that earlier, I am
 not experienced enough with NetBSD to know what is going on but it
 seems like something is halting the init.
 i915drmkms disabled:
 Bad CMOS battery, ignore the date warning. That is with
 hw.drm2.drm_debug=0xf, but I don't think it matters due to i915drmkms
 being disabled.
 >  The initial ACPI output looks weird, i.e. I doubt all those video outputs exist on the machine.
 >  I have no idea if that's anything more than a red herring, though.
 There is only one video output physically, the internal LCD, it
 doesn't even have a VGA port. I would've tried an external monitor if
 I could.
 >  You could enable debugging via the appropriate sysctl setting for more
 >  verbose output (assuming it gets that far, per previous question). To
 >  do so, you can set hw.drm2.drm_debug to a suitable value (e.g. 0xf) in
 >  /etc/sysctl.conf. That might tell us something more.
 Done, i915drmkms enabled with hw.drm2.drm_debug=0xf
 >  Something else you could try -- if you're really curious -- would be to
 >  enable the old i915drm driver instead, and see what happens there. (I
 >  used to use the old driver on my LG X110.)
 I tried that on 8.0, mentioned it in the original report. It booted,
 but no native resolution in console or X. It leaves me about where I
 am with the i915drmkms disabled.
 I did try booting 8.0 and current on an Asus Eee 901 with the same
 chipset, it didn't crash and I got native resolution at the console.
 The system is in poor condition and I couldn't do much with it though.

Home | Main Index | Thread Index | Old Index