NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-i386/53062: panic: SPL NOT LOWERED ON SYSCALL EXIT

The following reply was made to PR port-i386/53062; it has been noted by GNATS.

From: Robert Elz <kre%munnari.OZ.AU@localhost>
Subject: Re: port-i386/53062: panic: SPL NOT LOWERED ON SYSCALL EXIT
Date: Wed, 07 Mar 2018 18:27:29 +0700

     Date:        Wed,  7 Mar 2018 07:35:01 +0000 (UTC)
     From:        Jose Luis Rodriguez Garcia <>
     Message-ID:  <>
   |  With a kernel compiled with DEBUG and LOCKDEBUG I obtain this error from
   |  kernel (green color):
   |  execve_loadvm: check exec failed 8
 That's just from having DEBUG enabled, when an attempt is made to exec
 something which is not executable - which, while not all that common, is also
 not that unusual or special.   On NetBSD -current the message would include
 the path that failed to exec, but that's not in the message in -7 or -8.   The
 "8" in the message is ENOEXEC (NetBSD -current won't print the debug message
 in that case - but -7 and -8 still do - it was deleted as it is really not 
 You should be able to recreate it easily enough by copying some random
 binary file (not an executable or .o file etc) to /tmp/foo making sure 'x' 
 permission is set, then simply try to run /tmp/foo - that message should
 appear (from a DEBUG kernel) without any other effects (obviously no
 attempt will actually be made to run /tmp/foo - though depending upon
 which shell you use, it might try to interpret it as a script - in fact that
 is probably the easiest demo, use
 	echo I ran
 (just that one line, no #! at the start) as /tmp/foo.   You should see the
 message from the kernel (the DEBUG message) followed by "I ran" when
 the shell interprets the script.
 Sorry this is no help with the actual cause of the probem, but it might help
 by avoiding wasting time on irrelevant issues.

Home | Main Index | Thread Index | Old Index