NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-arm/53042: Raspberry pi GPU programs fails with "* failed to add service - already in use?"

>Number:         53042
>Category:       port-arm
>Synopsis:       Raspberry pi GPU programs fails with "* failed to add service - already in use?"
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    port-arm-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Feb 20 12:55:01 +0000 2018
>Originator:     Michael Blatt
>Release:        NetBSD 8.99.12 pkgsrc 2017_Q4
I can't get any program to run that tries to use GPU acceleration on
my RPI 1b rev2 (earmv6hf).
Tried this with both a self-built image and Jun's latest image (so 8.99.12),

Even hello_triangle.bin under /usr/pkg/src (not /usr/pkgsrc), part of
raspberrypi-userland, returns this error when run:

 * failed to add service - already in use?

With Linux this error message has historically been caused by firmware
issues, or a suboptimal gpu_mem split. I've tried gpu_mem=32, 64, 128
and even 256, to no avail.
I've also swapped the firmware for older versions that I've been using
on my RPI2 with NetBSD (same version).
1. download raspberrypi image

or the build server images (earmv6hf or earmv7hf)

2. copy to microsd

gunzip < 2018-02-11-netbsd-raspi-earmv6hf.img.gz |dd of=/dev/rsd0d bs=4m

3. setup Raspberry PI 0/1/2/3
- microsd card
- connect HDMI
- USB keyboard

4. extract pkgsrc 2017_Q4

5. build misc/raspberrypi-userland

6. build hello_triangle from /usr/pkg/src/hello_pi/ or any other example program that uses 3D acceleration. Note that this needs some paths adjusted and LD_LIBRARY_PATH specified when running.
This also applies to any package that uses 3D acceleration.
not known

Home | Main Index | Thread Index | Old Index