NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/52364: System hangs not much before showing the login prompt; changes in VFS suspected

>Number:         52364
>Category:       kern
>Synopsis:       System hangs not much before showing the login prompt; changes in VFS suspected
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jul 03 22:55:00 +0000 2017
>Originator:     Mateusz Poszwa
>Release:        NetBSD 8.99.1 2017/06/27 12:21
Mateusz Poszwa
System: NetBSD Bell 7.99.71 NetBSD 7.99.71 (GENERIC) #2: Sun Jul 2 17:59:05 CEST 2017 beb@Bell:/home/beb/sysbuild/amd64/obj/home/beb/sysbuild/src/sys/arch/amd64/compile/GENERIC amd64
Architecture: x86_64
Machine: amd64
	Note: Times specified in CEST (UTC +2).

        Initially, the system booting proceeds as
        usual. Messages from device detection and init
        scripts are visible (dhcp and xdm among others).

        When the procedure comes close to the point in which it
        would normally show a login prompt (either xdm, or, with
        xdm turned off, the text-based one) the system hangs:
        messages stop appearing and the prompt is not visible.
        After some time, the disk spins down, probably due to
        power-saving capabilities. If xdm is turned on, the
        system manages to switch to an empty VT before hanging.

        In some versions closer to the last working one, it
        was possible to switch VTs (all missing the login
        prompt). In newer versions it is no longer possible.

        Pressing Ctr-Alt-Esc brings up ddb on the first VT, but
        as my keyboard is connected through a USB port (and a
        PS/2â??USB adapter) I cannot issue commands (Iâ??m sorry).
        Try to boot NetBSD-current from 2017/05/17 18:00 source
        (7.99.71 at the time) or later. I tried several times
        with 7.99.73, .74, .75, and some versions of 8.99.1 up to
        2017/06/27. The earlier version and date comes from bisecting
        the problem with precision up to two kernel-specific commits.

	A version before
	worked fine. A version after
	did not.

        I deleted my build directory before realising these two
        changes were not a single commit. I can check the last
        remaining version (between the two changes) on request.

        Since I do not know of anyone facing a similar problem,
        it is highly probable that it is specific to my
        hardware or configuration. Fortunately, it seems
        to be reproducible every time I try. Any help with
        supplying the relevant details will be appreciated.
	Boot into single user mode.
	# fsck -fy
	# mount -rw /
	Replace the kernel with a version from 2017/05/17 12:00 source.
	# shutdown -r now

	Note that no changes to the userspace programs are necessary.
	8.99.1 userspace programs seem to work fine with 7.99.71 kernel.

Home | Main Index | Thread Index | Old Index