NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/52123: hme interfaces do not work anymore (7.0.2, 7.1)

>Number:         52123
>Category:       kern
>Synopsis:       hme interfaces do not work anymore (7.0.2, 7.1)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Mar 29 07:30:00 +0000 2017
>Originator:     Timo Schoeler
>Release:        7.0.2 and 7.1
Cannot provide at the moment.
I tried to install NetBSD 7.0.2 and NetBSD 7.1 (which was out recently when I first tried) onto my Sun Ultra 2 Enterprise. It features, amongst an additional FB (which the Enterprise version needs for video), two quad port hme S-Bus cards.

When installing NetBSD and having Ethernet connected to the on board hme0 interface, probing DHCP fails (see pictures below). After reboot, I tried again to make a connection.

First, the interface is in 100/HDX mode (which is odd as it is connected to a switch; no VLAN tagging, just an access port in Cisco speak). Running dhclient fails. After that, the interface is in FDX mode (for whatever reason). Trying static IP addressing also fails.

I verified this for some other ports (on the quad cards).

Interestingly, it works out of the box running OpenBSD 6.0 (both for the on board interface as well as the quad hme cards).

Pictures of all this:
Install NetBSD, see no networking.

Home | Main Index | Thread Index | Old Index