NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

install/51503: 7.0.1/amd64 USB install image root mount fails when sd present

>Number:         51503
>Category:       install
>Synopsis:       7.0.1/amd64 USB install image root mount fails when sd present
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Sep 24 08:55:00 +0000 2016
>Originator:     Andreas Gustafsson
>Release:        NetBSD 7.0.1

System: NetBSD
Architecture: x86_64
Machine: amd64

I recently installed NetBSD 7.0.1/amd64 on a HP DL360 G7 server.
Since the server lacks an optical drive, I tried a USB install as
documented at

When the kernel booted from the USB stick, the following messages
appeared on the console:

  boot device: sd1
  root on sd1a dumps on sd1b
  root file system type: ffs
  mount_ffs: /dev/sd0a on /: specified device does not match mounted device
  cp: /etc/gettytab: Read-only file system

Then, instead of sysinst starting automatically, I got a login prompt.
When I logged in as root and ran sysinst manually, it reported errors
at the point when it tried to write the network configuration to disk.

Running dmesg showed a logical volume of the server's RAID controller
as sd0, and the USB stick as sd1.

I was ultimately able to work around the problem and complete the
installation, but I'm reporting it so that it can be fixed for the
benefit of future NetBSD users.



Home | Main Index | Thread Index | Old Index