NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: PR/51230 CVS commit: src/sbin/gpt

The following reply was made to PR bin/51230; it has been noted by GNATS.

From: Robert Elz <kre%munnari.OZ.AU@localhost>
Subject: Re: PR/51230 CVS commit: src/sbin/gpt
Date: Fri, 10 Jun 2016 00:24:06 +0700

     Date:        Thu,  9 Jun 2016 15:35:02 +0000 (UTC)
     From:        Hauke Fath <>
     Message-ID:  <>
   |  Thanks! But...
   |  # bin/gpt-current sd0 biosboot -a -i1
   |  gpt-current: unknown option -- a
   |  Usage: gpt-current <device> biosboot [-c bootcode] [-i index] [-L label]
   |  #  
 Believe it or not, the correct usage is still "gpt biosboot [opts] device
 The usage message prints it in the order you show whenver the command
 name is not "gpt" (which it isn't for you).   I have no idea why, I see
 no code to support the devide first ordering (whatever the command name is)
 I suspect it is an artifact of that you're seeing (though I get a
 different message when I try it that way.)
   |  and gpt.8 renders to
   |       gpt biosboot [-ac bootcode] [-i index] [-L label]
 ALso, thanks for tracking down this problem, I noticed it back in Dec 2013,
 and worked out the fdisk (to put a regular MBR there) followed by gpt
 create (to convert that to a PMBR) solved the problem, and had worked out
 that gpt create on an uninit'd drive was not setting something properly,
 but I never got as far as working out what that was.
 I think though that Christos new -a flag should be changed (probably to -A)
 (througout) to avoid clashes with the "-a alignment" option that is
 used everywhere else (even the biosboot usage has a "[-a alignment]"
 option already in it .. just #ifdef'd out, the new -a would prevent that.)

Home | Main Index | Thread Index | Old Index