NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

toolchain/48835: compiler or assembler problem, shown by gdbm-1.11

>Number:         48835
>Category:       toolchain
>Synopsis:       gcc or assembler problem, shown by gdbm-1.11
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    toolchain-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri May 23 11:20:00 +0000 2014
>Originator:     Thomas Klausner
>Release:        NetBSD 6.99.41
Curiosity is the very basis of education and if you tell me that
curiosity killed the cat, I say only that the cat died nobly.
- Arnold Edinborough
Architecture: x86_64
Machine: amd64
I'm trying to compile gdbm-1.11 on NetBSD-6.99.41/amd64 using "gcc
(NetBSD nb2 20140304) 4.8.3" and the standard "./configure && make".

When I do that on a 6GB partition, it quickly stops with "file system
full", so I tried on a bigger partition.

After it was taking longer than I expected, I stoppped the process after
  CC       gdbmtool.o

and see:
# ll src/gdbmtool.o
-rw-rw-r--  1 wiz  users  549755886467 May 23 10:54 src/gdbmtool.o

du -sh on the whole gdbm-1.11 tree says "2.3G", so the 500GB probably contains 

The assembler process doesn't look too bad, sizewise:
11465 wiz       85    0    30M 9504K STOP       0:06  0.00%  0.00% as

# as --version
GNU assembler (NetBSD Binutils nb1) 2.23.2

When I interrupt at this point, I get a zombie as:
wiz       11465  0.0  0.0       0       0 pts/3  Z              -   0:00.00 (as)
and "du -sh" on the tree hangs.

I've also tried with "clang version 3.5 (trunk 202566)", and stopped
it at

# ll src/gdbmtool.o-4c09db31
-rw-rw-r--  1 wiz  users  665387008 May 23 11:29 src/gdbmtool.o-4c09db31

du -sh says on the whole gdbm-1.11 tree says "641M" at that point.

When I interrupt here, the temporary .o file is deleted and the tree
is back down to 6.1M.

I don't think these files should grow that big.

Note: configure adds "-g -O2" to the compiler flags when it finds gcc,
but even if I change that to "", I have the same problem.

Note2: If you let gcc run too long, you have a very big file that
will take ages to delete if you have log enabled, or might hang
your machine. You have been warned.
See above.


Home | Main Index | Thread Index | Old Index