NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

toolchain/48623: x68k-current build failure on FreeBSD/amd64

>Number:         48623
>Category:       toolchain
>Synopsis:       x68k-current build failure on FreeBSD/amd64
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    toolchain-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Feb 27 10:10:00 +0000 2014
>Originator:     Tetsuya Isaki
>Release:        NetBSD-current
FreeBSD 8.2-RELEASE-p9 amd64
x68k-current (20140227) build fails at sys/arch/x68k/stand/boot
with a strange error message on FreeBSD-8.2/amd64 host.
This failure continues from at least 20140101.
(I have no build log during from 201308 to 201312 :(
Last successful build is 20130801 on this host.

Of course, I tried a clean build, but got the same result.

On the other hand, the build on NetBSD-6.1/i386 succeeded
with the same source tree (20140227) shared by NFS.

Therefore, I think that some problem happened in a crossbuild
tool during from 201308 to 201312.

The uname which build fails is "FreeBSD 8.2-RELEASE-p9 amd64".

build log is
dependall ===> sys/arch/x68k/stand/boot
    compile  boot/boot.o
    compile  boot/conf.o
       link  boot/boot
/var/obj/current/x68k/tools/bin/m68k--netbsdelf-ld: boot.sym: can not represent
section `.SUNW_ctf' in a.out object file format
/var/obj/current/x68k/tools/bin/m68k--netbsdelf-ld: final link failed: Nonrepres
entable section on output

*** Failed target:  boot
*** Failed command: /var/obj/current/x68k/tools/bin/m68k--netbsdelf-ld -N -stati
c -T /autobuild/current/src/sys/arch/x68k/stand/boot/boot.ldscript -o boot.sym s
rt0.o boot.o conf.o exec_image.o vers.o /var/obj/current/x68k/obj/sys/arch/x68k/
stand/libsa/lib/sa/libsa.a /var/obj/current/x68k/obj/sys/arch/x68k/stand/libsa/l
ib/kern/libkern.a /var/obj/current/x68k/obj/sys/arch/x68k/stand/libsa/lib/z/libz
.a /var/obj/current/x68k/obj/sys/arch/x68k/stand/libiocs/libiocs.a
*** Error code 1

nbmake[10]: stopped in /autobuild/current/src/sys/arch/x68k/stand/boot

*** Failed target:  dependall
*** Failed command: cd "/autobuild/current/src/sys/arch/x68k/stand/boot"; /var/o
bj/current/x68k/tools/bin/nbmake realall
*** Error code 1

>How-To-Repeat: -m x68k release on FreeBSD/amd64
I don't know.

Home | Main Index | Thread Index | Old Index