NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bin/48140: dhcpcd fails to get lease in -current

>Number:         48140
>Category:       bin
>Synopsis:       dhcpcd fails to get lease in -current
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Aug 21 08:55:00 +0000 2013
>Originator:     Andreas Gustafsson
>Release:        NetBSD-current, cvs date >= 2013.
System: NetBSD
Architecture: i386
Machine: i386

Previously, when I have run NetBSD under qemu and specified the options
"--net user --net nic,model=ne2k_pci" on the qemu command line, I have
been able to connect to the Internet from the qemu guest.

I recently tried the same thing using a fresh NetBSD-current, and was
unable to get a DHCP lease.  Running "dhcpcd" as root, I see:

  dhcpcd[382]: version 6.0.0 starting
  dhcpcd[382]: ne2: waiting for carrier
  dhcpcd[382]: timed out
  Aug 21 08:17:07  dhcpcd[382]: timed out
  dhcpcd[382]: allowing 8 seconds for IPv4LL timeout
  dhcpcd[382]: timed out
  dhcpcd[382]: forked to background, child pid 381

Using an automated binary search, I have determined that the last
working version was CVS date 2013., and the first broken
one is 2013.  This is when dhcpcd-6.0.0 was imported.

This was tested using qemu version 1.2.0.  I have not tried
reproducing the problem on a physical machine, so those may or may not
be affected.

If I manually run "ifconfig ne2 up" before starting dhcpcd, it works.


$ sudo pkg_add qemu
$ ftp
$ qemu-system-i386 --nographic --snapshot --cdrom boot-com.iso --net user --net 

When prompted for a terminal type, just hit enter.

When sysinst starts, type control-c to get a shell prompt.

# dhcpcd


Home | Main Index | Thread Index | Old Index