NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-xen/47157: No Howto for NetBSD/xen 6.0

The following reply was made to PR port-xen/47157; it has been noted by GNATS.

From: Andreas Gustafsson <>
Subject: Re: port-xen/47157: No Howto for NetBSD/xen 6.0
Date: Mon, 22 Apr 2013 21:02:32 +0300

 On Feb 22, John Nemeth wrote:
 >  But, the short answer is install whatever version you want.
 So, I tried installing a NetBSD 6.0.1 dom0, xenkernel41-4.1.4, and
 xentools41-4.1.4nb2 on amd64, and ran into a number of issues.
 Although not all of them are issues with the HOWTO as such, I will
 list them all here anyway in an attempt to give a more complete
 picture of what obstacles someone installing NetBSD/xen might
 Issue 1: After successfully installing a binary package of xenkernel from
 I found that there was no corresponding binary package of xentools.
 I worked around this by building xentools from source.
 Issue 2: the HOWTO says to start xend using
   /usr/pkg/share/examples/rc.d/xend start
 but taken literally, this results in an error:
   /usr/pkg/share/examples/rc.d/xend: WARNING: $xend is not set properly - see 
   $xend is not enabled - see rc.conf(5).
   Use the following if you wish to perform the operation:
     /usr/pkg/share/examples/rc.d/xend onestart
 Issue 3: When instead trying the command
   /usr/pkg/share/examples/rc.d/xend onestart
 the message "Starting xend." is printed, but I don't get a shell
 prompt back.  The proctree command shows:
  | |   |-+= 01075 root /bin/sh /usr/pkg/share/examples/rc.d/xend onestart 
  | |   | \-+- 00871 root /usr/pkg/bin/python2.7 /usr/pkg/sbin/xend start 
  | |   |   |--= 01348 root (python2.7)
  | |   |   \--- 00489 root (blktapctrl)
 Looking at the port-xen archives, I see that others have had the same
 problem and that the solution is to start xencommons before xend.  But
 the HOWTO does not mention xencommons at all.
 Issue 4: The HOWTO says
   xend will write logs to /var/log/xend.log and /var/log/xend-debug.log
 but in actuality, the log files are in /var/log/xen, not /var/log.
 Issue 5: After manually starting xencommons and xend (in that order),
 I tried installing a NetBSD 5.2 domU and running the ATF tests using
   anita --vmm xen test
 This ended in a domU kernel panic while running the fs/tmpfs/t_rename
 test.  This is reproducible, and also happens with a 5.1 domU, though
 the exact test where the panic happens varies; so far, it has happened
 in fs/tmpfs/t_rename, fs/tmpfs/t_remove, and fs/tmpfs/t_link.  A 6.0.1
 domU is not affected by this.
 Andreas Gustafsson,

Home | Main Index | Thread Index | Old Index