NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

install/47599: Cannot boot NetBSD after reinstall

>Number:         47599
>Category:       install
>Synopsis:       Cannot boot NetBSD after reinstall
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Feb 27 16:15:00 +0000 2013
>Originator:     Chris Burt
>Release:        6.0.1
6.0.1 NetBSD 6.0.1 (GENERIC) amd64
Installing NetBSD from CD on a single hard disk (160GB SATA) works OK - 
partitioned disk, installed packages, rebooted and it worked fine.

I then booted from the NetBSD CD to install again, but this time used the same 
disk partition settings I had previously set up, installed packages, rebooted 
and received the error NetBSD MBR, No Operating System.

I repeated the same process, this time slightly adjusting the size of one of 
the partitions and it worked fine.

It seems like reinstalling the system using previously defined disk partition 
settings causes an error.

Here is the partition info I used:

NetBSD# df -h 
Filesystem         Size       Used      Avail %Cap Mounted on
/dev/wd0a           16G        63M        15G   0% /
/dev/wd0f           66G        66M        63G   0% /var
/dev/wd0e           38G       945M        35G   2% /usr
/dev/wd0g           16G        16M        15G   0% /home
tmpfs              2.0G       4.0K       2.0G   0% /tmp
kernfs             1.0K       1.0K         0B 100% /kern
ptyfs              1.0K       1.0K         0B 100% /dev/pts
procfs             4.0K       4.0K         0B 100% /proc

Please see Full Description.
Adjusting the size of one of the partitions for a reinstall works around the 

Home | Main Index | Thread Index | Old Index