NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-i386/46783: Boot hang on install CD

On 8/7/12 7:30 PM, Mark Davies wrote:
The following reply was made to PR port-i386/46783; it has been noted by GNATS.

From: Mark Davies <>
Subject: Re: port-i386/46783: Boot hang on install CD
Date: Wed, 8 Aug 2012 14:28:24 +1200

  On Wed, 08 Aug 2012, you wrote:
  > >Environment:
  > Dell Optiplex 755 and Dell Optiplex 990
  > System: NetBSD 6.0_BETA2 NetBSD 6.0_BETA2 (GENERIC) i386
  > Architecture: i386
  > Machine: i386
  > >Description:
  > Boot on i386 install CD causes a hang when the CD can not be
  > mounted as root.   It appears to allow one to continue by typing
  > in the cd0d but there is no console input working.   It is totally
  > hung.  This happens on both a Dell Optiplex 755 and Dell Optiplex
  > 990.   The amd64 version boots sucessfully on both machines.   The
  > following is the dmesg from the amd64 since I was not abe to
  > collect the i386 version.
I can confirm the same (i386 install cd hangs, amd64 ok) for Optiplex
  755, Optiplex 760, Optiplex 780 and Optiplex 990.  i386 install cd
  works for Optiplex 620 and Optiplex 745.
Interestingly while most 760's fail, while I was testing just now I
  found 1 760 that worked with i386 install cd.  Looking to see what was
  different about this machine -- at one point it ran windows xp so its
  bios sata operation setting had been changed from the default AHCI to
  ATA.  Setting it back to AHCI gets the hang.  I haven't tried the same
  test on the other machines.

I can confirm both the originally-reported problem (i386 cd boot fails, amd64 cd boot succeeds) on my newly-built system with a Gigabyte GA-H67-USB3-B3 motherboard, and the workaround: if I switch the SATA controller to IDE mode from AHCI in the BIOS, it boots OK under i386.

When it hangs, it then panics somewhere in USB as soon as I hit a key on the USB keyboard.

Home | Main Index | Thread Index | Old Index