NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bin/46148: cvs(1) broken in NetBSD 6.0_BETA

The following reply was made to PR bin/46148; it has been noted by GNATS.

From: Matthew Mondor <>
Subject: Re: bin/46148: cvs(1) broken in NetBSD 6.0_BETA
Date: Tue, 6 Mar 2012 19:44:53 -0500

 On Tue,  6 Mar 2012 23:45:04 +0000 (UTC)
 Matthew Mondor <> wrote:
 >  If doing src, xsrc, pkgsrc checkouts and updates from the
 >  netbsd-6/amd64 pserver to a non-tmpfs, it all seems to be successful
 >  and stable so far.  I'll leave a few automated checkout/update runs
 >  running and report again later.
 What the script did was cvs checkouts of src, xsrc of netbsd-3,
 netbsd-4-0, and  netbsd-current (no tags specified), over pserver.
 Then I ran find on some top-level files to make sure there were no such
 files randomly scattered in the tree (a very partial test), with no
 such occurances.  I would suspect that cvs update -dP would then reveal
 any serious inconsistency.
 So I ran a small script doing a cvs update -dP into the src and xsrc of
 the three trees.  I again checked for some top-level directory copies
 using find, with no results.
 So I ran a third small script which updated the netbsd-3 and netbsd-4-0
 src and xsrc trees also using -A, to trigger real updates.  Afterwards,
 a cvs -q update -dP still remained silent (no files to update, no
 abnormal files in the way).
 I'm sorry that I still couldn't reproduce what you're seeing, because
 if the issue isn't really in CVS, it's probably a more complex
 problem :(  It however was still worth the time, as if I had observed
 such CVS instability I would consider this PR critical.
 Is it certain that the repository you're checking out from has not been
 corrupted?  And that there are no known disk issue (none reported via
 atactl smart status either)?  What FS and mount options were you
 using?  This system uses FFSv2, mounted with log, noatime.

Home | Main Index | Thread Index | Old Index