NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-atari/44849: ENOMEM loading winbindd, smbd on Atari

>Number:         44849
>Category:       port-atari
>Synopsis:       ENOMEM loading winbindd, smbd on Atari
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    port-atari-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Apr 10 09:35:00 +0000 2011
>Originator:     David Ross
>Release:        5.1
NetBSD tt030 5.1 NetBSD 5.1 (MYKERNEL) #0: Mon Dec 13 22:03:51 PST 2010  
dross@new-host-5:/usr/obj/sys/arch/atari/compile/MYKERNEL atari
I have a 16MB Atari TT030 with a decent amount of swap.  I built/installed 
Samba 3.5.* twice and both times I get "Cannot allocate memory" starting smbd 
and winbindd.  Results w/ktrace:

tt030: {89} ktrace -id /usr/pkg/sbin/winbindd
ktrace: exec of '/usr/pkg/sbin/winbindd' failed: Cannot allocate memory

I tried setting resource limits higher but no luck.

I was actually able to upgrade the box to 256MB of physical memory 
(temporarily) but still got the same error.

It makes sense that I'd be having these issues because these two binaries are 
likely the largest on the system.  But still, I'd like to get to the bottom of 
this and be able to use the latest Samba on this box, if at all possible.

I did not experience this issue with a previous version of NetBSD (5.0.1?) with 
a previous version of Samba (3.0) -- everything just worked.
Compile Samba 3.5.8 on NetBSD 5.1/atari via pkgsrc.  After installing it, try 
to run /usr/pkg/sbin/winbindd or /usr/pkg/sbin/smbd.  Observe the binaries will 
not load.

Home | Main Index | Thread Index | Old Index