NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/44002: 3ware 9690 (ld driver) doesn't respond after transfer big amount of data

The following reply was made to PR kern/44002; it has been noted by GNATS.

From: David Holland <>
Subject: Re: kern/44002: 3ware 9690 (ld driver) doesn't respond after
 transfer big amount of data
Date: Sat, 27 Nov 2010 00:56:15 +0000

 On Tue, Nov 23, 2010 at 10:45:04AM +0000, Jiri Novotny wrote:
  >  Hmm, I don't think that it is just issue of unclean system. 
  >  To be sure I made new filesystem: newfs -O2 -s -64m dk0
  >  I havo no data on the RAID yet, so I don't need to play with fsck.
  >  The behavior is still the same. New screenshots are here:
 Ok, that's definitely broken; if it persists after merging the other
 fix please file a new PR, as it's almost certainly a FS bug and not a
 driver issue.
  >  >  Also, if you're using wapbl and don't have this change:
  >  >  
  >  >
  >  >  
  >  >  you'll probably want to pull it in. It's been pulled up to the various
  >  >  5.x branches so "cvs update" should get it for you without any further
  >  >  hassle.
  > It is little bit issue for me. It needs kernel with vfs_wapbl.c
  > r1.38.  I tried the change this in 5.1RC4, but it needs another
  > file - sys/wapbl_replay.h, O.K. I load it as well, but there were
  > bunch of bugs when I tried to compile the kernel.
 Ah, sorry, you want the change, not the whole of version 1.38. The
 version you want is (for 5.1_STABLE) or (for
 5.1.0_PATCH) or (for 5.0.2_PATCH).
 Or you can apply the patch yourself by doing
    cvs update -j1.37 -j1.38 vfs_wapbl.c
 but this will probably require you to hand-edit conflicts in the rcsid
  >  I downloaded the new 5.1, but the wapbl is the same as in 5.1RC4.
 Yeah, unfortunately that fix didn't make it into 5.1.
 David A. Holland

Home | Main Index | Thread Index | Old Index