NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-i386/43453: Can't boot NetBSD i386 normally or with DOSBOOT: "Not a bootxx image"

>Number:         43453
>Category:       port-i386
>Synopsis:       Can't boot NetBSD i386 normally or with DOSBOOT: "Not a bootxx 
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-i386-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Jun 11 02:40:01 +0000 2010
>Originator:     Thomas Mueller
>Release:        NetBSD 5.1_RC2
NetBSD amelia 5.1_RC2 NetBSD 5.1_RC2 (GENERIC) #0: Fri May 21 04:32:33 UTC 2010

I can't boot NetBSD normally from the hard drive; I ge the error message "Not a 
bootxx image".  This occurs with LILO, and also when I try to boot the 
partition with grub4dos, running from FreeDOS.  I also have Linux and FreeBSD 
8.0 on the main hard drive and FreeDOS on a smaller (1.2 GB) hard drive in a 
mobile rack.  When I try to boot from FreeDOS using DOSBOOT.COM, it hangs in 
the middle before I get to any dmesg stuff.  This problem has persisted since 
NetBSD 5.0.2.  NetBSD 4.0, 4.0.1, 5.0 and 5.0.1 booted OK; NetBSD 4.0 and 4.0.1 
only with DOSBOOT because that was, and still is, on a USB stick, which my BIOS 
can't boot from; I copied the kernel to the FreeDOS partition.  I even tried 
installing some update patches to NetBSD 5.0.2 before 5.1_RC1 was released.  
Problem seems to be with the primary bootstrap.

Only way I can boot NetBSD generic kernel now is by making a small .iso image 
with installboot and makefs following the example in the installboot man page, 
and I can boot that using grub4dos running under FreeDOS.  I have to hit the 
spacebar to interrupt the boot so I can then type "boot netbsd -a" and override 
the default root of cd0a in favor of wd0a.  That worked successfully.  I also 
tried filesystem images msdos and ffs, with the netbsd kernel and bootstrap, 
but could not boot any of those with grub4dos (try syslinux, bot how to make an 
appropriate hard-disk image?)

I am open to suggestions on what NetBSD emailing lists I should subscribe to 
(port-i386, users, any other?).
It happens every time I try to boot NetBSD from LILO menu, though Linux, 
FreeDOS and FreeBSD boot normally.
A semi-fix as described under the "Full Description".  Apparently bootxx_cd9660 
is OK.

Home | Main Index | Thread Index | Old Index