NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/42318: chroot or pkg_comp causes a hang on netbsd-5

>Number:         42318
>Category:       kern
>Synopsis:       chroot or pkg_comp causes a hang on netbsd-5
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Nov 14 21:25:00 +0000 2009
>Originator:     Louis Guillaume
>Release:        NetBSD 5.0_STABLE - sources from Nov. 11, 2009
System: NetBSD 5.0_STABLE NetBSD 5.0_STABLE (GENERIC) #9: Thu 
Nov 12 22:02:50 EST 2009 i386
Architecture: i386
Machine: i386
        After upgrading my NetBSD-5.0_STABLE, i386 system, I attempted to 
update a
        pkg_comp chroot environment to upgrade my packages. I unpacked the 
        kernel and base, comp, etc and text sets from the recent build 
        release). Then I ran postinstall to clean up and everything seemed to be
        working fine.

        I entered the chroot environment with "sudo pkg_comp chroot" and then
        began to run pkg_rolling-replace as usual. Now the process hung while 
        the "pkg_chk -uq" to figure out what was out-of-date. From a different
        session, I was able to kill the pkg_comp process, figuring this was all 
        fluke of some kind.

        Then I chrooted again. This time, upon simply executing "pkg_chk -uq" 
        whole system hung! I was not able to get an ssh session, and the console
        took the user part of the login but froze before prompting for password.

        I Ctrl-Alt-Esc'd to get to the debugger and it said...

        fatal breakpoint trap in supervisor mode
        /netbsd: trap type 1 code 0 eip c05788dc cs 8 eflags 202 cr2 cd4e2000 
ilevel 6
        syslogd: restart

        After the "restart" it tried to sync disks, printed a bunch of `2's and
        hung. I had to cold reboot it.

        This was repeatable each time I attempted to use pkg_comp for just about
        anything other than going into the chroot itself.

        I decided something was wrong with pkg_comp and decided to re-create my
        environment. So I started fresh with pkg_comp makeroot. And things seem
        to be working quite well.

        But I just found a hang when unmounting the pkg_comp filesystems (which
        are null-mounted). Interrupt will not kill the process and it's not
        responsive to a regular kill. It responded to a CTRL-Z, (susp), but if
        I try to "kill %1" I get "/bin/ksh: kill: %1: No such process".
        But that may be just because of using "sudo", I don't know.

        Root was able to kill the chroot process with no issue, but the "umount"
        command is still running anyway, unkillable even with `9'.

        The system hasn't hung again, but this is the kind of thing that was
        happening before right before it hung. 

        Not sure, but try to run pkg_comp (or perhaps other chroot operations)
        with netbsd-5 from at least Nov. 11th.



Home | Main Index | Thread Index | Old Index