NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: install/38752: 4.99.63 corrupts superblock

The following reply was made to PR install/38752; it has been noted by GNATS.

From: Roy Marples <>
Subject: Re: install/38752: 4.99.63 corrupts superblock
Date: Thu, 3 Jul 2008 23:29:13 +0100

 On Tuesday 27 May 2008 22:15:04 Roy Marples wrote:
 >  More info on this - this disk itself is fine.
 >  The issue is with SMP. By chance I installed the non SMP 4.0 kernel and
 >  everything worked. So I obtained a -current kernel, /boot and /boot.cfg
 > and booted with the -1 option to disable SMP and that works fine also.
 >  This means that my Intel Core2 Quad fails to SMP on my Abit IP35 Pro
 >  motherboard with both NetBSD 4.0 SMP and 4.99.63. The BIOS is current as
 > of today, compiled on 20080318. For reference, Gentoo Linux amd64 has no
 > trouble running on this platform, all CPUs are active and appear to be
 > working fine.
 >  The symptom with -current in SMP is now a hang after detecting the disk on
 >  wd0. init is not reached.
 More info again :)
 I've updated to -current dated 20080807, (4.99.69 IIRC)
 By chance I noticed a new BIOS for my motherboard.
 Flashing it didn't make any difference, but whilst setting some options I 
 broke my USB keyboard in the BIOS. So I plugged my trusty ps/2 keyboard in 
 and voila - SMP started working.
 After around 10 reboots and unplugging, replugging the PS/2 keyboard each time 
 I had 5 fails and 5 successes for SMP. The USB keyboard was still plugged in, 
 and fully working if the system booted.
 During this testing, I enabled MPDEBUG and the debugger dropped in after each 
 CPU failed to become ready. Just before the hang, it dropped again - but this 
 time it said cpu1 failed to start and entered the debugger. At this point usb 
 keyboard is frozen (worked to continue past the 3 cpu failed to become ready 
 messages) and needed to cold boot.
 I have no idea if that's enough for you guys to fix this or not.
 FWIW, FreeBSD-7.0 and OpenBSD-4.3 will not boot on this box either. Although 
 I'll be re-testing with a ps/2 keyboard plugged in and submitting pr's for 
 them if it then works.
 Gentoo Linux works just fine, so I'm sure that this is fixable :)

Home | Main Index | Thread Index | Old Index