NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/39016: processes stuck in "tstile"

>Number:         39016
>Category:       kern
>Synopsis:       processes stuck in "tstile"
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jun 22 09:30:00 +0000 2008
>Originator:     Alan Barrett
>Release:        NetBSD 4.99.63
Not much
System: NetBSD 4.99.63
Architecture: i386
Machine: i386
        The system sometimes gets into a state such that all processes that
        attempt to perform disk I/O get stuck waiting for "tstile".
        Just use the system for a while.

        For example, most recently, I was running X, a mail reader,
        systat vm, a few idle shells, "cp -RPp" copying from one
        external USB disk to anotehr, a "make" job using rsync to copy
        from an external machine to the local machine, and a recursive
        "chown".  I noticed that the window manager's clock had stopped
        updating.  Upon further investigation, I noticed:

        * The window manager's clock display had frozen;
        * The external USB disks were still busy;
        * The systat display had frozen;
        * Pressing enter in an idle shell still worked;
        * Attempting to run any new command hung forever;
        * The "make" job that was synchronising from an external machine
          had printed a message saying that it was performing a "rm" command
          to delete a lock file, but then appeared to be stuck;
        * Pressing alt-control-F1 to get to the primary console worked;
        * Pressing alt-control-escape to get into DDB worked;
        * Inside ddb, the "ps" and "ps /w" commands indicated that many
          processes were waiting for "tstile";
        * One of the stuck processes was "rm", which I presume was the
          command invoked from the make job menjioned above;
        * The ddb "c" command worked;
        * At the login prompt on the primary console, typing a username and
          pressing enter caused the "login" proess to get stuck waiting
          for "tstile" (or perhaps it was the "getty" process that was stuck,
          I am not certain);
        * the ddb "sync" command caused the machine to freeze, requiring
          a power cycle.

        Prior to this event, I had noticed from the "systat bufcache"
        display that there was no free memory; most memory was in use by
        cached file system data.

Home | Main Index | Thread Index | Old Index