NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/38683: T61 cannot suspend with recent kernels

>Number:         38683
>Category:       kern
>Synopsis:       Thinkpad T61/amd64 cannot suspend with recent kernels
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun May 18 02:55:00 +0000 2008
>Originator:     Steven M. Bellovin
>Release:        NetBSD 4.99.63
Department of Computer Science, Columbia University
System: NetBSD 4.99.63 NetBSD 4.99.63 (YELLOWSTONE) 
#0: Fri May 16 23:56:11 EDT 2008
Architecture: x86_64
Machine: amd64
        My Thinkpad T61 (running amd64) cannot suspend/resume with recent
        -current kernels.  It suspends; at resume time, it prints
        ioapic0 renabling -- and nothing more happens.  The crescent 'suspend'
        light stays on.  I also have some evidence that the system will
        overheat if I leave it in this state for too long; for fairly obvious
        reasons, I'm not inclined to experiment further on that point...

        I've tried disabling [eou]hci and azalia via 'boot -c'; that didn't
        help.  If I diable ioapic, it does resume; however, the keyboard
        is dead, so it's not a very useful workaround.

        I don't know just when this started.  I'm running a kernel from
        March 7; it works.  However, I can't upgrade, since every kernel I've
        built in the last few weeks exhibits this problem.

        I've tried a kernel that works for Jared; it does not work for me.
        As far as I know, the primary difference between his machine and
        mine is that I have a fingerprint reader and Bluetooth; those, however,
        show up as USB devices, so disabling [eou]hci should have prevented
        any problems from them.
        Boot to single-user and do 'sysctl -w machdep.sleep_state=3'.
        Alternatively, try any other way to suspend, such as shutting
        the lid or hitting Fn+F4.


Home | Main Index | Thread Index | Old Index