Subject: Re: port-macppc/36891: NetBSD-current 4.99.1 or later don't boot
To: None <>
From: SUNAGAWA Keiki <>
List: netbsd-bugs
Date: 09/04/2007 22:57:45

> The following reply was made to PR port-macppc/36891; it has been noted by GNATS.
> From: SUNAGAWA Keiki <>
> To:,
> Cc:,,
> Subject: Re: port-macppc/36891: NetBSD-current 4.99.1 or later don't boot
>  on PowerBook G4 (late 2004)
> Date: Tue, 04 Sep 2007 19:39:46 +0900 (JST)
>  Michael, thanks for your reply.
>  >  How exactly does it fail? 'does not boot' can mean quite a few 
>  >  different things.
>  Oh, sorry.  It hangs just after printing "console keyboard
>  type:" message.  Please take a look at the thread started
>  from my message posted to port-macppc in July.
>  >  And, did you try anything newer than 4.99.1 or did you narrow the 
>  >  failure down to this version?
>  Yes.  Actually I tried the version as of July, then did
>  binary search to find the point of breakage.  Not tested
>  latset one though, so I try it soon.

Well, I must have lost some point.

Booted 4.99.1 kernel with ofwboot.xcf, it stops in the
middle of its boot process, but with ofwboot.elf, it
successfully boots and works well.  I'm using the 4.99.1
kernel to write this message.

Happily enough, I happen to have a little earlier model of
PowerBook G4 at hand.  So I tried on this machine and got
an interesting result.

It successfully loads (since no NetBSD partition on it) both
of 4.99.1 and 3.99.24 kernels with ofwboot.elf.  But with
ofwboot.xcf, It goes bad after putting the message
'avail memory=238MB'.  If I typed "boot hd:,ofwboot.xcf
netbsd-4.99.1.gz", it fell into a infinte loop of trap.  If
I typed "boot hd:,ofwboot.xcf -a" then "netbsd-4.99.1.gz"
into ofwboot.xcf's prompt, it silently hangs at the point.

Best regards,