Subject: Re: port-alpha/36628: cdhdtape image panics with memory management trap on Jensen
To: None <,,>
From: Christoph Franzen <>
List: netbsd-bugs
Date: 08/01/2007 16:00:06
The following reply was made to PR port-alpha/36628; it has been noted by GNATS.

From: "Christoph Franzen" <>
To: Izumi Tsutsui <>
Subject: Re: port-alpha/36628: cdhdtape image panics with memory management trap on Jensen
Date: Wed, 01 Aug 2007 17:59:46 +0200

 > Hmm, it looks there is some problem around PIC initialization.
 I'm not sure if you already know this, and if it helps:
 This is a detailed description of the Machine's system board 
 including the interrupt controller.
 When I was searching for information on my hard disk here, I didn't 
 find this any more, but fortunately it was still available at
 > Anyway, there is a report that ahb(4) works on AlphaServer
 > (no device is connected to ahb(4) though)
 > so this may be a Jensen specific problem.
 According to the Mailinglist, older Netbsd versions have been 
 successfully run on the Jensen, and that would have been impossible 
 without ahb(4), because the Jensen's SRM CANNOT boot from elsewhere. 
 The Alphaserver hardware is quite different from the Jensen (in fact, 
 there is nothing like the Jensen except the Culzean, which I never 
 have heard of in the real world).
 > There is no reference code about the interrupt controller on Jensen so
 > I have no idea of proper solutions, but could you try this one (with
 > both "a" and "n" flags)?
 I tried "a" at first, it stopped at this line like one of the 
 previous versions:
 stray eisa irq 12; stopped logging
 Sending Break to the serial console did not help. (Perhaps I had been 
 waiting too long?) After pressing the halt switch, I booted with flag 
 "n" with the same result, except that I was able to enter ddb(4) this 
 time. The events showed a great number of unhandled IRQ 12.
 Hans-Juergen Bergmann, who has tried to get Netbsd running on the 
 Jensen a few years ago, has answered to my email. Unfortunately, he 
 did not succeed, and had given up, but he has agreed to help testing 
 when his machine arrives in a month or so (he has moved to Oakland). 
 He has got two AHA1742A controllers, perhaps one of these has a 
 different MCODE revision. Later ones were reported to have less 
 problems. (VMS would not run on revision E, the one I have here.)
 Regards, Christoph