Subject: install/34280: cannot boot install media via serial
To: None <,,>
From: None <>
List: netbsd-bugs
Date: 08/25/2006 18:45:00
>Number:         34280
>Category:       install
>Synopsis:       cannot boot install media via serial
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Aug 25 18:45:00 +0000 2006
>Originator:     George Georgalis
>Release:        3.1_RC1 (also 3.0.1 and 3.0_RELEASE)
Metrum Research Group
not posible, per port-amd64/34259 no keyboard either but this boot is
3.1_RC1 cdrom via usb on amd64 x86_64
Booting the 3.1_RC1 cdrom with console redirect to serial port (per
BIOS) I use condev com2 and proceed to boot the install media. However,
serial stops and boot proceeds on VGA, after kernel checksum. eg

> consdev com2                                                                  

>> NetBSD/amd64 BIOS Boot, Revision 3.2                                         
>> (, Sun Aug 20 22:12:26 UTC 2006)                         
>> Memory: 630/2096064 k                                                        
> boot                                                                          
booting fd0a:netbsd

This is a show stopper because the blade system has no PS/2 and both
the chassis USB KVM and keyboard via blade USB have problems,
(port-amd64/34259) ie no console possible. Tried PXE/NFS with 3.0.1 but
require new bge code in 3.1x for network connectivity (hopefully), or
maybe I didn't do PXE+NFS+HEAD_Kernel properly... tried hard.
I have reproduced the problem on another amd64 (a 1-u with no PS/2),
where I installed 3.1_RC1 via PCI CDROM and USB keyboard.

> consdev com1
> boot hd1a:
booting hd1a:netbsd
6405232+670512+375440 [472512+288327]=0x8d5688

That machine does have networking and a uname -a of:

3.1_RC1 NetBSD 3.1_RC1 (GENERIC) #0: Sun Aug 20 22:47:46 UTC 2006 amd64 x86_64
Provide a kernel with bootstrap for each of console= com1,com2...
or make the magic of passing boot consdev=XX to the kernel :-\