Subject: port-amd64/28586: building generic on amd64 fails using rc5
To: None <,,>
From: Wouter Schoot <>
List: netbsd-bugs
Date: 12/08/2004 10:33:00
>Number:         28586
>Category:       port-amd64
>Synopsis:       building generic on amd64 fails using rc5
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-amd64-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Dec 08 10:33:00 +0000 2004
>Release:        NetBSD 2.0_RC5
System: NetBSD 2.0_RC5 NetBSD 2.0_RC5 (GENERIC) #0: Sun Nov 14 08:51:13 CET 2004 tecneeq@ascent:/home/tecneeq/builds/NetBSD-2.0_RC5-amd64-obj/sys/arch/amd64/compile/GENERIC amd64
Architecture: x86_64
Machine: amd64
I tried to build a custom kernel on my amd64 but it didn't quite work out. tools went fine, nbconfig went fine too, but nbmake'ing it failed. Tried GENERIC and it had about the same. cross-building the kernel for amd64 on another arch works fine. This is with cvs checkout from 2.0-release from a few hours ago from the main cvs server. nbmake depend fails on something with linux compat.. Commented that out, and then it still fails, but not in depend anymore.
# Build the tools
cd /usr/src
./ tools

# GENERIC, with only options         COMPAT_LINUX commented out
/usr/src/tooldir.NetBSD-2.0_RC5-x86_64/bin/nbconfig GENERIC
cd ../compile/GENERIC/

/usr/src/tooldir.NetBSD-2.0_RC5-x86_64/bin/nbmake depend goes fine, 
/usr/src/tooldir.NetBSD-2.0_RC5-x86_64/bin/nbmake fails. 

I put the output on my webserver because it's quite some text: