Subject: bin/23551: mrouted and/or ethereal packet disagreement
To: None <>
From: None <>
List: netbsd-bugs
Date: 11/23/2003 10:07:24
>Number:         23551
>Category:       bin
>Synopsis:       mrouted and/or ethereal packet disagreement
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Nov 23 18:08:00 UTC 2003
>Originator:     Wolfgang S. Rupprecht
>Release:        NetBSD 1.6ZF
W S Rupprecht Computer Consulting, Fremont CA
System: NetBSD 1.6ZF NetBSD 1.6ZF (WSRCC_ATHLON) #1: Sun Nov 16 18:47:58 PST 2003 i386
Architecture: i386
Machine: i386

	mrouted and ethereal (from pkgsrc) disagree on what
	constitutes a valid packet.


	create an empty /etc/mrouted.conf file
	ethereal &
	<start it running via ^K>
	mrouted -d 3

	In ethereal expand the multicast packets marked "DVMRP" in the
	display window.  The packet shown are marked as garbled, and
	sure look garbled when compared to the RFC.

	(one can apply a multicast filter to make it easier to find
	the packets.  ip.dst == )

	It is not entirely clear which program is at fault.  I don't
	have a multicast peer to test against.  I was just wondering
	if multicast worked at my ISP and getting no reply from
	mrouted I tried to see if the other side was sending any