Subject: install/15739: NetBSD -CURRENT sysinst bugs.
To: None <>
From: None <>
List: netbsd-bugs
Date: 02/26/2002 01:53:33
>Number:         15739
>Category:       install
>Synopsis:       NetBSD -CURRENT sysinst bugs.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Feb 26 01:53:00 PST 2002
>Originator:     Murray Stokely
>Release:        snapshot/20020219-1.5ZA
FreeBSD Mall, Inc.
NetBSD-20020219-1.5ZA / i386
1. (cosmetic) After configuring an interface with DHCP, sysinst displays
   'none' for IP address although the DNS servers are listed properly and
   networking works, so clearly an address was assigned.

2. (serious) Default FTP install looks in the wrong directory.  I booted
   from a set of floppies I downloaded from the 20020219-1.5ZA directory,
   so sysinst should know where to look for its distribution sets.  The
   installer tried to grab the bits from /pub/NetBSD/NetBSD-1.5ZA/i386/binary/set
   and failed.  After I manually changed the FTP path, installation continued
   until the next bug :

3. I selected to install 'All' distribution sets at the beginning, but
   after downloading several distributions sucessfully, sysinst failed
   to fetch 'xbase' and then completely failed.  This distribution should
   really have simply been skipped, or at least given me the option to
   continue the installation without this file, but it completely bombed

Overall, there have been significant improvements to sysinst since the
last time I tried an install.  I hope that these bugs can be fixed.

Try to install NetBSD -CURRENT on an i386.  Hit the default choices for
most prompts, and watch the installation fail.

Sorry, I wish I had time to provide a diff.