Subject: Re: kern/11321: siop appears to hang my machine
To: Chris Jones <>
From: Manuel Bouyer <>
List: netbsd-bugs
Date: 10/29/2000 21:13:17
On Fri, Oct 27, 2000 at 02:54:54PM -0600, Chris Jones wrote:
> Okay, more data:
> With ddb.onpanic = 0, I get essentially the same behavior:  It locks
> up, and nothing happens.  I gave it five minutes, just in case it was
> taking a long time to write the crash dump before it rebooted.
> Also, it appears that the lockup actually happens when the chio SCSI
> command completes:  I can run the command, switch into X, and do stuff
> for a couple of minutes.  Then when the changer finishes moving its
> media around, the machine hangs.
> I tried Manuel's suggestion of doing lots of I/O, to see if that would
> trigger it:  no luck.  X was running at the time, but it was on a
> different terminal.  I stayed on ttyE0 and did a:
> # chio move slot 0 drive 0 & tar clf /dev/null /usr
> The tar took longer than the chio, and everything worked just fine.
> What next?  SCSIDEBUG?

If it can't be reproduced in text mode it'll be harder.
Any chance to connect through a serial console ?
Connect a null-modem cable between 2 PCs. On the one which will be the term
use tip to connect to the serial port:
tip console
(check /etc/remote that the console entry points to the rigth tty)
Boot the other PC and at the boot prompt type
consdev com0
(or com1 if the cable is connected to com1 :)
The boot prompt should now appear on the serial  term.
To enter ddb send a break:
enter ~ .

You should now be able to log in on anorther VT and start X

Manuel Bouyer, LIP6, Universite Paris VI.