Subject: Re: kern/11321: siop appears to hang my machine
To: None <>
From: Chris Jones <>
List: netbsd-bugs
Date: 10/27/2000 14:54:54
Okay, more data:

With ddb.onpanic = 0, I get essentially the same behavior:  It locks
up, and nothing happens.  I gave it five minutes, just in case it was
taking a long time to write the crash dump before it rebooted.

Also, it appears that the lockup actually happens when the chio SCSI
command completes:  I can run the command, switch into X, and do stuff
for a couple of minutes.  Then when the changer finishes moving its
media around, the machine hangs.

I tried Manuel's suggestion of doing lots of I/O, to see if that would
trigger it:  no luck.  X was running at the time, but it was on a
different terminal.  I stayed on ttyE0 and did a:

# chio move slot 0 drive 0 & tar clf /dev/null /usr

The tar took longer than the chio, and everything worked just fine.

What next?  SCSIDEBUG?


Chris Jones                                           Mad scientist at large