Subject: kern/10550: can't netboot from fxp0 any more
To: None <>
From: Martin Husemann <>
List: netbsd-bugs
Date: 07/09/2000 10:24:14
>Number:         10550
>Category:       kern
>Synopsis:       can't netboot i386 from fxp0 any more
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jul 09 10:25:00 PDT 2000
>Originator:     Martin Husemann
>Release:        1.5B, cvs updated July 8
System: NetBSD 1.5B NetBSD 1.5B (RUMOLT) #1: Sat Jul 8 16:59:11 MEST 2000 i386


I tried upgrading a 1.4 machine to current. This machine (fxp0 wiht nsphy)
boots from the network via dhcp/nfs. Now that our dhcpd is fixed, I tried
to compile a -current kernel for it and boot it, but it failed.

The server does not receive any bootp/dhcp request. The lights on the hub
blink a few times, but not packet seems to leave the booting machine.

The fxp0 is connected to a 100/10 MBit switch, autonegotiation always worked
for it (and when the lights blink, they always show 100MBit, full-duplex, which
is correct).


Try to netboot a -current machine via fxp0 with nsphy.