Subject: port-macppc/10540: Serial ports on MacPPC 1.4.2 have troubles
To: None <>
From: Donald Lee <>
List: netbsd-bugs
Date: 07/08/2000 16:42:14
>Number:         10540
>Category:       port-macppc
>Synopsis:       The serial ports on PPC Macs that have them don't work reliably.
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    port-macppc-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jul 08 16:43:01 PDT 2000
>Originator:     Donald Lee
>Release:        NetBSD 1.4.2
>Organization: (very small ISP)
	I have 3 configurations:
		PowerCenter 132, NetBSD 1.4.2
		Pmac 7600/132, NetBSD 1.4.2
		Beige G3 (OF 2.4), NetBSD 1.4.2
System: NetBSD 1.4.2A NetBSD 1.4.2A (try4) #2: Wed Apr 26 08:29:44 CDT 2000 macppc

	As far as I can tell, the serial ports on the macPPC platform
	do not work, except for the case when they are used as the
	serial console on tty00.  I can't get tty01 to work at all
	in most cases.  In some cases it will do output, but not

	I've tried some simple things to fix it, but nothing
	seems to help.  The serial driver is similar to the
	mac68K driver, and I've done a compare, but nothing
	jumps out at me, except that the macppc version seems
	a lot older.

	If I try to run getty or pppd on tty00 (killing the console) then
	it is not possible to get the console back.  It is
	necessary to reboot.

	I've tried this on my 7600, the PCenter, and the Beige G3, and
	the results are very similar.

	Is there something I could try to shed light on this?

	Easiest way to reproduce this is to run a getty on tty01
	(printer port).  Hook up a terminal, and watch it fail.