Subject: port-i386/9457: wiconfig(8) fails in /etc/netstart
To: None <>
From: Ed Gould <>
List: netbsd-bugs
Date: 02/20/2000 23:09:38
>Number:         9457
>Category:       port-i386
>Synopsis:       wiconfig(8) fails in /etc/netstart
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-i386-maintainer (NetBSD/i386 Portmaster)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Feb 20 23:09:00 2000
>Originator:     Ed Gould
Ed Gould	 Palo Alto Advanced Development	 Compaq Computer Corp.
+1 650 853 2108			 130 Lytton Avenue		 Palo Alto, CA 94301
>Release:        1.4T, probably 1.4S also
System: NetBSD rome 1.4T NetBSD 1.4T (ROME) #25: Sun Feb 20 18:30:51 PST 2000 ed@rome:/usr/src/sys/arch/i386/compile/ROME i386

	When wiconfig(8) is invokde in /etc/netstart, just before
	starting dhclient, the configuration is not set and the

		wi0: timeout in wi_seek to fc00/0; last status ffff

	is generated.  The same invocation worked with 1.4R (and might
	have worked with 1.4S).  It does work after the system is up

	In /etc/netstart:

	    if checkyesno dhclient; then
	      WL=`ifconfig -l | sed -e 's/.*\(wi.\).*/\1/'`
	      if [ -n "$WL" ]; then
		echo -n "configuring WaveLAN $WL ... "
		wiconfig $WL -p 1
	      echo -n "starting dhcp client...";
	      dhclient $dhclient_flags

	Note that the failure persists when wi0 is explicitly coded.)