Subject: xsrc/8548: Xsun core dumps
To: None <>
From: None <>
List: netbsd-bugs
Date: 10/04/1999 07:29:40
>Number:         8548
>Category:       xsrc
>Synopsis:       Xsun core dumps
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    xsrc-manager (NetBSD X11 bug manager)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Oct  4 06:50:01 1999

>Release:        1.4.1<NetBSD-current source date>
System: NetBSD cowboy-burt 1.4.1 NetBSD 1.4.1 (COWBOY-BURT) #1: Sat Oct 2 21:08:08 EDT 1999 dan@cowboy-burt:/amd/dinah-moe/export/src/sys/arch/sparc/compile/COWBOY-BURT sparc


Xsun dumps core.


run the program 'scilab' (available as math/scilab in the packages collection).
At the scilab prompt, enter:

stacksize(2000000); t=linspace(0,10,400000); plot(t,sin(t));

Xsun will crash.  This only happens when plotting with a lot of points (400,000
in this case).  For example,
t=linspace(0,10,40000); plot(t,sin(t));
which only does 40,000 points does not crash.

It doesn't matter if scilab is running locally or not.  For example, if I run scilab
on a remote machine with the display set back to my NetBSD-1.4.1/sparc, it still crashes
Xsun.  Also, I've tried this on a NetBSD-1.4.1/mac68k machine (display set to the mac)
and Xmac68k does _not_ crash.

none yet.