Subject: lib/7447: nsswitch is broken, or I'm seriously confused
To: None <>
From: Jason R Thorpe <>
List: netbsd-bugs
Date: 04/22/1999 16:53:18
>Number:         7447
>Category:       lib
>Synopsis:       nsswitch is broken, or I'm seriously confused
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    lib-bug-people (Library Bug People)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Apr 22 16:35:00 1999
Numerical Aerospace Simulation Facility - NASA Ames
>Release:        Simon's NetBSD 1.4_BETA snapshot for pmax
System: NetBSD sulaco 1.4_BETA NetBSD 1.4_BETA (GENERIC) #21: Wed Apr 21 12:05:53 EST 1999 root@mona:/usr/src/sys/arch/pmax/compile/GENERIC pmax

	Ether nsswitch is broken, or I am seriously confused.  Wanting
	to get away from old compat-style passwd files, I changed my
	/etc/nsswitch.conf to read:

passwd: files nis

	From my reading of the manual page, this would cause it to
	check files first, and if not found, consult nis.

	However, user "thorpej" no longer existed, according to
	finger(1).  It worked once I changed it back to "compat".
	`ypmatch thorpej passwd.byname' worked fine, even when
	finger(1) didn't.
	See above.

	No idea.  Help!  *whimper*