Subject: port-amiga/5672: system works unreliable with more than two memory segments
To: None <>
From: Matthias Scheler <>
List: netbsd-bugs
Date: 06/28/1998 15:31:01
>Number:         5672
>Category:       port-amiga
>Synopsis:       system works unreliable with more than two memory segments
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    gnats-admin (GNATS administrator)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jun 28 06:35:00 1998
>Originator:     Matthias Scheler
Matthias Scheler                      
>Release:        980626
NetBSD 1.3F NetBSD 1.3F (SANDRA) #0: Sat Jun 27 01:49:13 MEST 1998 amiga

After I successfully updated to a 1.3F kernel I tried to rebuild userland.
But "gcc" choked while compiling "libc":

cc -O  -Werror -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith  -DNLS -DYP -DLIBC_SCCS -DSYSLIBC_SCCS -D_REENTRANT -I/usr/src/lib/libc/include -D__DBINTERFACE_PRIVATE -DRESOLVSORT -DPOSIX_MISTAKE -DFLOATING_POINT -c /usr/src/lib/libc/gen/getloadavg.c
/tmp/cc00374a.s: Assembler messages:
/tmp/cc00374a.s:45: Error: Ignoring junk after expression
*** Error code 1


Neither getting the sources again nor installing 1.3.2's "gcc" fixed the
problem. Because these kind of problems (see PR bin/5403) started after
I added memory to my system(*) I tried to boot using only two memory segments
and the problem vanished. I tried it several and the results was always
the same: if I boot with two memory segments (either bootblock with options
"netbsd -AS -n 1" or "GoBSD netbsd AGA MULTIUSER TWOSEG") the compile
works fine. If I boot with three memory segments (either "netbsd -AS -n 2"
or "GoBSD netbsd AGA MULTIUSER MAYSEG") the compile fails on "getloadavg.c".

(*) The configuration looks like this:

24MB on CyberStorm MK III 040
16MB on mainboard
8MB on Z3 Fastlane

Boot a system with more than two memory segments and try a "make build"

Sorry, I don't know.