Subject: kern/5570: adding routes useful can become impossible.
To: None <>
From: None <>
List: netbsd-bugs
Date: 06/11/1998 11:00:22
>Number:         5570
>Category:       kern
>Synopsis:       adding routes useful can become impossible.
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    kern-bug-people (Kernel Bug People)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Jun 11 04:05:00 1998
>Originator:     matthew green
people's front against (bozotic) www (softwar foundation)
>Release:        <NetBSD-current source date>1.3E
System: NetBSD 1.3E NetBSD 1.3E (_splode_) #373: Sun Apr 26 14:18:04 EST 1998 sparc


	i've seen this twice, now, over the past few months, on either end
	of the same ppp connection:

	when i try to add routes on a machine that has a route to a ppp
	interface, (default or otherwise, it seems), with a gateway of a
	machine that a route entry already exists for (a machine also on
	local ethernet in both cases), the new routes "interface" is the
	ppp interface, not the ethernet interface.  this of course totally
	loses.  i tried using the "-iface" option to route, but it did not
	change anything.

	another data point here is that both local ethernets are C class
	networks, that have been subnetted, and that the destination of the
	route was a separate subnet of the class C address.

	i also tried running routed with a /etc/gateways but it didn't seem
	to work either (it didn't seem to like specifying any sort of network

	set up netbsd box with local class C network, subnetted, with a
	router between the two networks.  attach a ppp interface and make
	this he default route.  then try to add a route to the router to
	access the other local subnet.