Subject: pkg/5229: ghostscript 5.10 has severe bugs
To: None <>
From: Charlie Root <>
List: netbsd-bugs
Date: 03/29/1998 05:22:40
>Number:         5229
>Category:       pkg
>Synopsis:       ghostscript 5.10 has severe bugs
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    gnats-admin (GNATS administrator)
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sun Mar 29 04:20:00 1998
>Originator:     Charlie Root
Tim Rightnour    -
>Release:        1.3<NetBSD-current source date>
System: NetBSD polaris 1.3 NetBSD 1.3 (POLARIS) #0: Thu Mar 26 13:17:18 MST 1998 root@polaris:/usr/src/sys/arch/i386/compile/POLARIS i386

I have an Epson Stylus 500 Printer. (color).  I upgraded to ghostscript5.10 in the pkg
tree, and immediately it began dumping core on everything I printed.  I sent a bug-email
off to aladdin and got the following back:

Thanks for the problem report.  Unfortunately, the traceback you sent is
garbage: the routine in stack frame N is almost never one that is actually
called from the routine in frame N+1.  It's possible for this to actually be
the case if memory has gotten scrambled badly enough, but I've never seen it

There is a known problem in gs 5.10 that can cause memory access errors when
printing any PostScript file that has dashed lines or curves, especially on
color printers.  If this is the problem, I suggest you drop back to 5.03.
If you get memory access errors with files that don't include any dashed
lines, please resubmit the bug form with a specific PS file that causes the

Reverting to 5.03 solved the problem.. Everything works great now.

Try to print a 1040 Schedule D on an Epson Stylus 500 printer.  Actually, dies too, as do about 50% of the .ps files I tried to print.

Downgrade the pkgtree ghostscript to 5.03 until aladdin fixes the bug.