Subject: Re: internal modem bug
To: Jay Nelson <>
From: Don Ray <>
List: netbsd-bugs
Date: 03/17/1998 23:47:51
-----Original Message-----
From: Jay Nelson <>
To: Don Ray <>
Cc: netbsd port-i386 <port-i386@NetBSD.ORG>
Date: Tuesday, March 17, 1998 7:48 PM
Subject: Re: internal modem bug

>This is just a wag -- but if getty's causing a problem, make sure
>(on the modem) that echoing is turned off and verify that &C1, &K3,
>&S1 and &D2 (usr) or &D3 (zoom) is set.

Hi Jay & everyone,

Actually, I had already gone through the hardware handshaking and
local/remote echo AT command trials but you got me thinking about it again.
After several more iterations of AT settings, I hit on the result codes
setting Qn. The &f1 (hardware defaults) of the USRobotics defaulted to Q0 -
display result codes. Changed it to Q1 - suppress result codes  =) viola!
that fixed it! I'm still not sure what that fixes - I'd thought local/remote
echo (e0/f1) would've been good enough.

Whatever it is, not being a problem in 1.3 threw me off a bit.

Thanks to everyone that gave this any thought.

And thanks again Jay for puttin' me back on track!
Don Ray - Service Technologies
Voice: 216-473-5653