Subject: Problems Installing Software
To: None <netbsd-bugs@NetBSD.ORG>
From: Doug Barth <>
List: netbsd-bugs
Date: 03/02/1998 22:23:57
To whom ever this may concern,

     I am attempting to install NetBSD on my Mac. I am running a Quadra 
650 with 40MB of RAM installed. There is a 3.1GB internal SCSI hard drive 
installed. I running System 8.1 with one partition formatted as an HFS+ 
drive. However, all the NetBSD info is installed on a different partition 
which is standard HFS. Now, the problem that I am having is with the 
first opening sequence of the installer program. I ran the Mkfs program 
and formated a Root, Usr, and Swap partition. However when I run the 
installer program, I get a strange problem. By the way, I have disconnect 
the external SCSI chain and turned off all extensions. This is exactly 
the way the log reads:

  sd0 at scsi ID 0.
  Partition read, SCSI ID = 0
  Mounting partition 'A' as /
  sd0a: Root 'NetBSD Root' at 4176700 size 307200
  sd0g: Usr 'NetBSD Usr' at 4688700 size 1695744
  sd0b: Swap 'NetBSD Swap' at 4483900 size 204800
  sd0d: HFS_PART 'MacOS' at 204 size 1064248
  sd0e: Other (APPLE_PATCHES) 'Patch Partition' at 192 size 12
  sd0f: HFS_PART 'MacOS' at 1064452 size 1064248
  sd0h: HFS_PART 'MacOS' at 2128700 size 2048000
  Error on SCSIRead(), #5
  failed mountfs(), error 22.
  Error mounting root.
  mount root.  : Undefined error: 0

This is exactly what appears on the screen when we try to install it. We 
have given the application up to 20MB to work with. Also we tryed to run 
it with the program in the same folder as all the sets. Please return a 
message telling me how to solve this problem.