Subject: NetBSD 1.1 (and ALPHA) and A4000T/040
To: None <netbsd-bugs@NetBSD.ORG>
From: Kimmo Mustonen <>
List: netbsd-bugs
Date: 05/05/1996 14:19:04

I tried to install NetBSD 1.1 and 1.1 ALPHA on my system, A4000T/040 but 
neither of them worked. :( It displays the following texts and stops. 
Keyboard is not being read anymore. Some problems with IDE or 
SCSI-controllers that are built-in in A4000T? :(

Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.

NetBSD 1.1_ALPHA (GENERIC) #0: Tue Nov 14 10:44:45 EST 1995
Amiga 4000 (m68040 CPU/MMU/FPU)
real  mem = 16777216 (2048 pages)
avail mem = 14491648 (1769 pages)
using 115 buffers containing 942080 bytes of memory
memory segment 0 at 07000000 size 01000000
memory segment 1 at 00000000 size 00200000
mainbus0 (root)
clock0 at mainbus0: system hz 100 hardware hz 709379
ser0 at mainbus0: input fifo 512 output fifo 32
par0 at mainbus0
kbd0 at mainbus0
grfcc0 at mainbus0
grf0 at grfcc0: width 640 height 400 colors 4
ide0 at grf0: rows 50 cols 79 repeat at (30/100)s next at (10/100)s has 
fdc0 at mainbus0: dmabuf pa 0x1e3030
fd0 at fdc0: 3.5dd 80 cyl, 2 head, 11 sec [9 sec], 512 bytes/sec
idesc0 at mainbus0afsc0 at mainbus0
afsc0: <cursor>

It seems like the line with idesc0 and afsc0 is a bit wrong, I think (if 
it's in the same format as the previous lines) there should be a line 
feed between them. And then, it hangs at afsc0 (the SCSI-controller?).
I have 1+7 SCSI devices attached. No IDE devices. Any idea?

I have tried to start it with command: 'loadbsd -b -I sync-inhibit 
netbsd', but it didn't help. I also tried the debug mode but as I didn't 
know how to execute one subroutine (bsr or jsr) at a time (with command s 
it would have taken hours and hours), I wasn't able to find anything. :(

Best Regards,
Kimmo Mustonen