Subject: NetBSD Security Advisory 2000-011
To: None <>
From: None <>
List: netbsd-announce
Date: 08/08/2000 23:47:35

                 NetBSD Security Advisory 2000-011

Topic:		vulnerability in netscape versions prior to 4.74
Version:	NetBSD pkgsrc prior to 25th July 2000.
Severity:	buffer overrun in JPEG parser.


Note:  The Netscape Communicator and Navigator packages are not part
of the base NetBSD distribution, and are not installed by default. 
They are part of the NetBSD package collection, which contains a large
number of third-party applications in ready-to-install format.

NetBSD makes no claim about the suitability or security of these
third-party applications; however, when we become aware of severe
security holes in commonly used packages, we may release advisories
such as this one.

Netscape's processing of JPEG comments trusted the length parameter
for comment fields; by manipulating this value, it is possible to
cause netscape to read in an excessive amount of data, overwriting
memory.  Specially designed data could allow a remote site to execute
arbitrary code as the user of netscape.

This vulnerability has been fixed in Netscape 4.74.

Solutions and Workarounds

Versions of Netscape Communicator and Navigator older than version
4.74 are vulnerable.  To find out the version of Communicator or
Navigator installed on your NetBSD system, you can use pkg_info(1):

	# pkg_info -e communicator-\*
	# pkg_info -e navigator-\*

If Communicator or Navigator is not installed on your system, no
output will be generated, and your system is not vulnerable to this

If you have a version older than 4.74, you should upgrade to version
4.74 (or newer) of Netscape Communicator and/or Navigator.  A
corrected version has been part of the NetBSD packages collection
since 25th July 2000.

If a vulnerable version of Communicator or Navigator is installed,
then you should immediately remove the vulnerability by deleting the
package.  As root, type:

	# pkg_delete -v communicator-\*
	# pkg_delete -v navigator-\*

If you continue to need Communicator or Navigator, you should install
a new version of the package.

You can use the pkgsrc infrastructure to download the precompiled
binaries directly from their home site.  First, make sure that you
have a version of the pkgsrc hierarchy from 25th July 2000 or later. 
(See for ways to obtain NetBSD,
and pkgsrc, its packages collection.)

You can then install the new version of the packages:

	cd pkgsrc/www/communicator; make clean; make install


	cd pkgsrc/www/navigator; make clean; make install

For more information on how to rebuild a package from source for your
architecture, see

Thanks To

Alistair G. Crooks <>

Revision History

	2000/08/02	original draft
	2000/08/08	release

More Information

Information about NetBSD and NetBSD security can be found at
http://www.NetBSD.ORG/ and http://www.NetBSD.ORG/Security/.

Copyright 2000, The NetBSD Foundation, Inc.  All Rights Reserved.

$NetBSD: NetBSD-SA2000-011.txt,v 1.3 2000/08/09 02:33:36 sommerfeld Exp $

Version: 2.6.3ia
Charset: noconv