Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: booting xen [was Re: serial console puzzle]

On Fri, Apr 30, 2021 at 07:28:57PM +0100, Patrick Welche wrote:
> On Fri, Apr 30, 2021 at 07:00:38PM +0200, Manuel Bouyer wrote:
> > On Fri, Apr 30, 2021 at 05:55:37PM +0100, Patrick Welche wrote:
> > > no luck. I see loading /netbsd-XEN3_DOM0, and then it just reboots.
> > > Nothing more appears on the console. (-current XEN, xen.gz from xenkernel415)
> > 
> > Try xen-debug.gz ?
> > Do you get the Xen boot messages ?
> I don't get the Xen boot messages. Just tried xen-debug.gz and again I just
> see loading, and then a reboot. I don't think it gets as far xen*.gz.
> boot.cfg contains:
> menu=Boot Xen:rndseed /var/db/entropy-file;consdev com0,57600;load /netbsd-XEN3_
> DOM0 console=com1 com1=57600,8n1,0x3f8;multiboot /xen-debug.gz dom0_mem=1024M
> [Any one know how to avoid "Collecting System Inventory ..." so booting
> doesn't take forever?]

Bizarre observation:


menu=Boot normally:rndseed /var/db/entropy-file;consdev com0,57600;boot
menu=Boot single user:rndseed /var/db/entropy-file;consdev com0,57600;boot -s
menu=Boot Xen:rndseed /var/db/entropy-file;consdev com0,57600;load /netbsd-XEN3_DOM0 console=com1 com1=57600,8n1,0x3f8;multiboot /xen-debug.gz dom0_mem=1024M
menu=Drop to boot prompt:prompt

If I press "1", I still get "loading /netbsd-XEN3_DOM0" and a spontaneous
reboot. I need to press "2", then ctrl-D in single user for the equivalent
of "1".



Home | Main Index | Thread Index | Old Index