Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Unusable system during dd to USB block device


I just accidentally tried to write about 3 gigabytes of data with dd
to USB disk via the block device instead of raw device.

The transfer did work, but it was excruciatingly slow, under 2 Mb /
sec. But that wasn't the only problem: it also made most other
activities on the system unusable, at least if there was any disk
access involved.

Looking at the system with top, there was only marginal user and
system time usage. The dd process was mostly blocked on "needbuf", and
so were the other processes that responded slowly. And not everything
was blocked, processes that weren't using disk did respond normally.

Afterwards I tried to rewrite the image through the raw device, and
that worked without problems, about 20 Mb / sec.

This was on a few months old -current, on amd64. The laptop has 6 Gb
mem, and there was plenty of free memory at the time.

Is this something known, or should I file a PR? Obviously writing a
disk image using the block device is not the right way to do it, but
neither should the system slow down the way it did.


Home | Main Index | Thread Index | Old Index