Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: build failure when optimizing

On Tue, 26 May 2020 23:01:36 +0200 wrote:

> Hej again,
> > Am 24.05.2020 um 01:06 schrieb Tobias Nygren <>:
> > 
> > On Sat, 23 May 2020 22:25:55 +0200
> > wrote:
> > 
> >> I just tried to build release with optimisation for my little xeon server.
> >> That fails, but I don?t understand why it seems to build some 386 32bit libs.
> > 
> > You can build with MKCOMPAT=no to avoid this problem if you don't need
> > 32-bit compatibility libs.
> Thanks again, MKCOMPAT really is case-sensitive, so no is better than NO, but nevertheless, im still not getting through the build process:
> ?schnipp?
> #   compile  ld.elf_so/mdreloc.o
> /hurz/obj/tooldir.NetBSD-9.99.63-amd64/bin/x86_64--netbsd-gcc -O2    -mfpmath=sse -msse3 -march=native  -fvisibility=hidden -O3 -fomit-frame-pointer -mno-3dnow -mno-mmx -mno-sse -mno-sse2
> -mno-sse3 -fstack-protector -Wstack-protector   --param ssp-buffer-size=1    -std=gnu99    -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wno-sign-compare  -Wsystem-header
> s   -Wno-traditional   -Wa,--fatal-warnings  -Wreturn-type -Wswitch -Wshadow -Wcast-qual -Wwrite-strings -Wextra -Wno-unused-parameter -Wno-sign-compare -Wsign-compare -Wformat=2  -Wno-for
> mat-zero-length  -Werror     --sysroot=/hurz/obj/destdir.NetBSD-9.99.64-amd64 -fPIC -DELFSIZE=64 -DRTLD_COMMON_CALL_IFUNC_RELA -DLIBDIR=\"/usr/lib\" -D_PATH_RTLD=\"/libexec/ld.elf_so\" -I/
> hurz/src/libexec/ld.elf_so -I. -D_KERNTYPES -DRTLD_LOADER -DGNU_RELRO -D_RTLD_SOURCE -DHAVE_INITFINI_ARRAY  -D_FORTIFY_SOURCE=2 -c    /hurz/src/libexec/ld.elf_so/arch/x86_64/mdreloc.c
> cc1: error: SSE instruction set disabled, using 387 arithmetics [-Werror]
> cc1: all warnings being treated as errors
> *** Failed target:  mdreloc.o
> ?schnapp?
> how comes?  And what can I do?

There is an -mno-sse2 flag on the command line and it conflicts with
your -mfpmath=sse flag. This COPTS setting comes from
src/libexec/ld.elf_so/Makefile. You can remove the flag but expect
random breakage, it is there for a reason. Probably the easiest fix is
to add something like CFLAGS:=${CFLAGS:N-msse*:N-mfpmath=sse} at the
bottom on the Makefile to undo your settings for this file only.

Home | Main Index | Thread Index | Old Index