Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Clearing ghosts of wedges (you forgot the subject line)

Martin Husemann wrote:
> On Tue, Feb 04, 2020 at 08:57:08AM -0500, MLH wrote:
> > $ gpt show wd2
> > GPT not found, displaying data from MBR.
> > 
> >        start        size  index  contents
> >            0  7814037135         Unused
> >   7814037135          32         Sec GPT table
> >   7814037167           1         Sec GPT header
> OK, this is causing some of the trouble.
> Try: gpt destroy wd2
> Maybe you need to "gpt recover wd2" first and then do the destroy.

Martin hit on how to solve the problem. I had tried everything that
has been suggested and all failed.

Martin's suggestion was that after doing a "gpt destroy wdx" (which
I had done several dozen times, followed by everything else), do
a "gpt recover wdx" and then another "gpt destroy wdx" and then

The key command was the recover... I have no idea why, but after
doing that and then destroying wdx again, then rebooting, I could
then delete all of the raid wedges and then all other wedges
successfully. And I could then rebuild the wedges, begin to configure
the raid and then all of the delete commands worked as they should
and didn't need the "gpt recover wdx" to delete them.

It also appears to have fixed the problem of wd2/wd3 disappearing
on boot.

So appears something got hosed that required doing the recover to

Now I need to get back to trying to get the thing to configure/install
raid0 and boot off of it. :^)

Thanks All!

Home | Main Index | Thread Index | Old Index