Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD 9.0_RC1 - installation on GPT (with BIOS boot) not bootable


I just tried 9.0 RC1 on a Lenovo Thinkpad X220. The device is configured to use (Legacy) BIOS boot but at partitioning I have chosen to use a GPT partition table. Within this table, there is only one 64 GB FFSv2- Partition.

The installation process with sysinst runs fine. Anyway, after reboot there seems to be no boot loader installed.

I tried to fix this with a shell from the USB installation media by doing a manual installboot & gpt biosboot to /dev/dk0. This also doesn't help.

Afterwards I repeated the whole installation but instead of a GPT partition table I have chosen MBR. This time after the installation the system renders bootable fine.

Is it a supported use case for sysinst to setup a non-EFI-System with GPT?

Kind regards

Matthias Petermann <> |
Innovative IT-Lösungen, Systemintegration, Linux/FreeBSD/Unix-Support
Wildparkring 13, 01458 Ottendorf-Okrilla | Tel.: +49 (0)35205 597 991

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Home | Main Index | Thread Index | Old Index