Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: problems upgrading go112 (and go111) on NetBSD-8.99.32/amd64

Thanks Benny for your suggestions!

At Mon, 15 Apr 2019 13:57:18 +0200, Benny Siegert <> wrote:
Subject: Re: problems upgrading go112 (and go111) on NetBSD-8.99.32/amd64
> Try rebuilding lang/go14 perhaps?

Yes, I've tried that a couple of times.  I even tried re-installing a
much older build of it, all with no change.

I thought I had older versions of go installed on this machine,
especially go110, but apparently I didn't keep pkg binaries for them.

> You could also try editing lang/go112/Makefile and setting
> GOROOT_BOOTSTRAP to /usr/pkg/go111.

I had not thought that would be possible (though it makes sense that it
should be), but...

No dice -- I see the exact same errors as with the bootstrap using go14.

I think the problem must lie in my host toolchain or libraries.

Is there any easy way to get the build scripts to show exactly what
commands are being run?

Is there anything I can examine in my working go111 install that might
reveal how it managed to build?

Is there anything I can compare between the "official" go112 (or go111)
package binaries for -current/amd64 and my build results?

At some point this week I can hopefully find time to try to install a
test system (domU) with a stock -current and pkgsrc and try building go
in that environment (though I expect that to work), but maybe I can then
compare the package-obj directories and see what might be different.

					Greg A. Woods <>

+1 250 762-7675                           RoboHack <>
Planix, Inc. <>     Avoncote Farms <>

Attachment: pgplf7vPntdB1.pgp
Description: OpenPGP Digital Signature

Home | Main Index | Thread Index | Old Index